Package Manager Tools Version

2/7 に提案がマージされたばかりですが、すぐに実装されそうです。

原文 swift-evolution/NNNN-package-manager-tools-version.md at 4eca7991a60186ba140b454476b274f9acc38599 · rballard/swift-evolution · GitHub

パッケージマネージャーツールバージョン

Swiftのパッケージごとに宣言されたSwiftツールのバージョンを使われます。パッケージの使用するためのSwiftツールの最小バージョンを指定できるようになります。 Swift3とSwift4の互換のために導入するために、3.1で導入されるようです。